Correction in Fee Page \ Corrección de Fee (Fe de Errata)
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted May 11, 2020 - 04:36 EDT
Monitoring
EN:
We have identified an issue with our fees page that was indicating an incorrect amount of 5 USD instead of 5 EUR for SEPA Withdrawals. This error was corrected but we wanted to inform our users to avoid confusion.

ES:
Hemos identificado un error en nuestra pagina de fees la cual indica que el monto para retiros de EUR en SEPA es de 5 USD en vez de 5 EUR. Este cambio ha sido corregido pero queriamos informarles por este medio para evitar confusiones
Posted May 08, 2020 - 08:35 EDT