Ethereum Network Congestion
Incident Report for Mercury Cash
Update
Under our monitoring, the result of our findings is that gas prices and congestion are still in place today we have increased our ETH fee was increased to cover network and internal expenses. This measure is temporary until the situation inside the ETH network stabilizes.
Posted Sep 02, 2020 - 02:28 EDT
Monitoring
Hi everyone, we have been monitoring the Ethereum Blockchain and currently based on the CONGESTION transactions could take a long time to be processed or even fail, please be aware before if you are considering sending any transaction to another wallet.
Posted Aug 12, 2020 - 11:19 EDT
This incident affects: Nodes (Ethereum Network).