Statement Generation / Generacion de Estados de Cuenta
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 16:25 EST
Investigating
Hemos detectado una falla en la generación de los estados de cuenta del mes de enero 2020, actualmente estamos aplicando correctivos para resolver el problema.

We have detected a failure in the statement generation for January 2020, we are currently applying a fix to solve this issue.
Posted Feb 07, 2020 - 07:01 EST
This incident affected: API.