Issues with Support Channels
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 16:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2020 - 16:25 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 28, 2020 - 11:15 EST
This incident affected: Website.