Latest transactions not being shown at the transaction section
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 17:24 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 10, 2020 - 10:49 EDT
This incident affected: Website.