iOS Safari & MAC Safari
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 06:20 EST
Monitoring
Our Engineering team has implemented a fix to resolve the issue with pricing timeouts globally and is monitoring the situation. We will post an update as soon as the issue is fully resolved
Posted Feb 12, 2020 - 07:53 EST
Identified
We have identified an issue with Safari Browser in iOS Devices and Mac Devices, we encourage you to use other browser while we fix the issue.
Posted Feb 06, 2020 - 10:53 EST
This incident affected: Website.