EUR withdraws issues
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 05:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 08, 2020 - 20:13 EDT
This incident affected: API.