BTC Transfers Issues
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 05:40 EDT
Monitoring
We have detected an error in our nodes, our engineers have been working for 2 hours to fix this issue, the transactions are now resumed and we keep monitoring the situation.
Posted Apr 09, 2020 - 00:04 EDT
This incident affected: Nodes (Bitcoin Network).