EUR Funding > Withdrawal Method
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted May 11, 2020 - 04:36 EDT
Identified
All EUR payments "withdraw method" will be unable on Thursday (2020.04.30) and Friday (2020.05.01) all EUR payments will resume on Monday (2020.05.04). our banking partner is in Holiday if you wish to withdraw you can use BTC, ETH or DASH, therefore, all of your inquiries will be responded to on Monday.
Posted Apr 30, 2020 - 09:42 EDT
Monitoring
All EUR payments "withdraw method" will be unable on Thursday (2020.04.30) and Friday (2020.05.01) all EUR payments will resume on Monday (2020.05.04). our banking partner is in Holiday if you wish to withdraw you can use BTC, ETH or DASH, therefore, all of your inquiries will be responded to on Monday.
Posted Apr 30, 2020 - 09:00 EDT
This incident affected: Payment Methods (SEPA Payments).