Possible issues with Document KYC Creation
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 17:15 EDT
Investigating
Our 3rd party KYC Provider has reported possible issues with their API which can give issues at the moment you upload your documents.

We are currently investigating this issue and will update when the impact is verified.
Posted Aug 07, 2020 - 11:06 EDT
This incident affected: Website (KYC Verification).