Statement Generation in XLS & CSV
Incident Report for Mercury Cash
Resolved
Dear Customers, Statements in XLS and CSV were generated and they are now available in your account. Thank you for your patience.
Posted May 03, 2020 - 16:41 EDT
Monitoring
We are implementing the new statements in the new formats (XLS & CSV), some of the PDF Statements are affected by this update process, We apologize for the inconvenience.
Posted May 01, 2020 - 14:28 EDT
This incident affected: Website.