UPDATE - Upgrading Mercury Cash 2.1.0
Incident Report for Mercury Cash
Resolved
We have successfully deployed Mercury Cash 2.1.0
Posted Mar 04, 2020 - 16:31 EST
Monitoring
We are performing an upgrade to our version 2.1, the website will be unavailable for approximately 30 minutes, We keep you updated.
Posted Mar 04, 2020 - 16:18 EST
This incident affected: API, Website, ID Verification, Digital Currencies, Customer Support, Cryptocurrency Purchases, Mobile (Android App, iOS Application), iOS Mobile App (iOS Mobile App), Website (Login, Sign Up, KYC Verification, SMS Verification), Nodes (Bitcoin Network, Ethereum Network, Dash Network), and Payment Methods (WIRE - Bank Transfers).