Overloaded Capacity on Approvals
Incident Report for Mercury Cash
Resolved
Everything back to normal. Thank you for your patience.
Posted May 11, 2020 - 04:36 EDT
Monitoring
Our head team is currently monitoring the number of users that registered due to the success of our zero fee campaign, we apologize for the inconvenience if your account is not approved in the time that we normally expect to be, this means that accounts might take longer time to be approved and processed.
Posted Apr 30, 2020 - 05:51 EDT
This incident affected: Website (KYC Verification) and Customer Support.