Sign Up > After 2FA Configuration no Alert of Approval Needed
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 06:20 EST
Monitoring
We have implemented an update into our system, we are currently monitoring it and we will post an update if it's resolved.
Posted Feb 12, 2020 - 07:55 EST
Identified
We have identified an issue that affects users that are currently registering, after applying 2FA the system doesn't indicate that the profile was successfully completed and the user needs to wait until compliance approves the account. We are currently working on this to provide a solution.
Posted Feb 07, 2020 - 05:47 EST
This incident affected: Website.