KYC System Failing
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 16:31 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 04, 2020 - 16:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2020 - 09:25 EST
Investigating
We currently experiencing issues with our KYC provider, the system to verify documents and identity is not loading correctly, we are in contact with this provider in order to get a fast solution.
Posted Feb 28, 2020 - 06:19 EST
This incident affected: Website (KYC Verification) and ID Verification.